Issue Details (XML | Word | Printable)

Key: UBA-7177
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Marcel Rüedi
Reporter: Janak Mulani
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
ULCBase

java.net.MalformedURLException if the webserver does no provide host address in Java URL format (e.g. in IPV6)

Created: 12/Mar/07 11:35 AM   Updated: 03/Feb/09 02:02 PM
Component/s: core
Affects Version/s: ULC 6.1.3
Fix Version/s: ULC 6.2.1

Time Tracking:
Not Specified

Issue Links:
Reference
 


 Description  « Hide
>java.net.MalformedURLException: For input string:
>"0000:0000:0000:280d:1fb5:53ef:e9e0:40000"
> at java.net.URL.<init>(URL.java:601)
> at java.net.URL.<init>(URL.java:464)
> at java.net.URL.<init>(URL.java:413)
> at com.ulcjava.container.servlet.server.ContainerCommand.a(ContainerCommand.java:0)
> at com.ulcjava.container.servlet.server.ContainerCommand.execute(ContainerCommand.java:46)
> at com.ulcjava.container.servlet.server.ServletContainerAdapterHelper.b(ServletContainerAdapterHelper.java:147)
> at com.ulcjava.container.servlet.server.ServletContainerAdapterHelper.service(ServletContainerAdapterHelper.java:121)
> at com.ulcjava.container.servlet.server.ServletContainerAdapter.service(ServletContainerAdapter.java:5)
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

>i did some investigation on this. the problem is that the
>webserver on vista returns an IPv6 address for the servername.
>according to javadoc URL ipv6 addresses have to be put between [].
>i was able to solve this problem
>because the servlet server is our own implementation.



 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Daniel Grob added a comment - 14/Nov/07 05:18 PM
The following is an extract from the mentioned JavaDoc of the URL class:

host can be expressed as a host name or a literal IP address. If IPv6 literal address is used, it should be enclosed in square brackets ('[' and ']'), as specified by http://www.ietf.org/rfc/rfc2732.txt; However, the literal IPv6 address format defined in http://www.ietf.org/rfc/rfc2373.txt is also accepted.