Issue Details (XML | Word | Printable)

Key: DOL-119
Type: Bug Bug
Status: Open Open
Priority: Minor Minor
Assignee: Dierk Koenig
Reporter: Andres Almiray
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Dolphin

Build failure with Gradle 2.0

Created: 04/Jul/14 04:48 PM   Updated: 05/Jul/14 08:40 PM
Component/s: infrastructure
Affects Version/s: 0.10
Fix Version/s: None
Security Level: public

Time Tracking:
Not Specified

Environment:
------------------------------------------------------------
Gradle 2.0
------------------------------------------------------------

Build time: 2014-07-01 07:45:34 UTC
Build number: none
Revision: b6ead6fa452dfdadec484059191eb641d817226c

Groovy: 2.3.3
Ant: Apache Ant(TM) version 1.9.3 compiled on December 23 2013
JVM: 1.8.0_05 (Oracle Corporation 25.5-b02)
OS: Mac OS X 10.9.3 x86_64

How-To-Repeat:
$ gvm use gradle 2.0
$ gradle build


 Description  « Hide
The build fails with Gradle versions greater than 1.10.
It would be great if the build was upgraded to be compatible with Gradle 2.0.
The following error appears when attempting to build with Gradle > 1.10
* Where:
Script '/Users/aalmiray/Projects/canoo/open-dolphin/buildSrc/scripts/docsDependencies.gradle' line: 20

* What went wrong:
A problem occurred evaluating script.
> Cannot get property 'grailsDocs' on extra properties extension as it does not exist

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED


 All   Comments   Work Log   Change History      Sort Order: Ascending order - Click to sort in descending order
Dierk Koenig added a comment - 05/Jul/14 08:40 PM
+1

I guess it would be a good strategy to resolve the pre-2.0 warnings and then do the upgrade, which should then go smoothly.

cheers
Dierk